Welcome to the RV White Water Retro Travel Trailer Enthusiast Forums!

A website dedicated to all things Riverside RV Retro, tips, tricks mods and more. We have many features on this website to make your experience here more enjoyable.

Join in and contribute your ideas and questions! FYI: You must register and login to post replies or start new topics.

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Water to Faucets
No permission to create posts
July 8, 2020
8:59 pm
Avatar
Gordon
New Member
Members
Forum Posts: 1
Member Since:
July 8, 2020
sp_UserOfflineSmall Offline

Help!  First-time user of our White Water.  I filled the water tank, opened the faucets, turned on water pump (heard it purring), and have no water coming from faucets.  By-pass valve is closed to water heater; all other valves appear to be open.  System works fine with pressurized city water.  Water pump appears to be operating properly except that I am not receiving water thoughout the system.  What am I overlooking?  I have read that the hot water tank needs to fill first, but I have had system running for 15-20 minutes without any success.  Ideas?  

Thanks!

September 16, 2020
1:22 pm
Avatar
TanishaLambertson
Member
Members
Forum Posts: 23
Member Since:
January 19, 2019
sp_UserOfflineSmall Offline

It sounds strange that water is not coming when everything is working fine. In my opinion, first of all, you should see the water pump pipe. Yes, in most case, I noticed that such things happen when your water pump bent or kinked. Similarly, it could be a faucet issue. I would recommend you to use any of good quality faucets or even faucet heads from here https://www.wowowfaucet.com/, and you would notice either it is faucet or its heads issue or not. 

On the other hand, it could also be a microswitch issue. Yes, in many whitewater retroes and even caravans, there is tiny microswitch under each tap. It would help if you examined them because in case they have failed a reason of this problem. Blocked water filters or pressure switch failure could also become a reason of this problem. I would like to recommend you to read this article https://www.hortoncommon.co.uk/tap-not-working-in-your-caravan-or-motorhome/ to understand precisely about your water issue. Yes, it is related to caravans and motorhomes, but their water system is similar in many cases. 

Forum Timezone: America/Denver

Most Users Ever Online: 177

Currently Online:
6 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

A.J.: 89

Alabama Jim: 54

mrseo12: 46

TanishaLambertson: 23

mkevenson: 22

Perrypridgen: 20

markstevens: 19

thatchick1120: 18

DAVID555: 18

amber_bowers: 17

Member Stats:

Guest Posters: 0

Members: 1156

Moderators: 1

Admins: 1

Forum Stats:

Groups: 5

Forums: 24

Topics: 396

Posts: 1395

Newest Members:

entranceielearning, hewettmr, Mitchell, LoisFletcher, Riley555, jjimjohn1, shawnkemp, Geremy, CraigMills, RyanHarper

Moderators: Roccosamore: 119

Administrators: Kristopher: 190