Welcome to the RV White Water Retro Travel Trailer Enthusiast Forums!

A website dedicated to all things Riverside RV Retro, tips, tricks mods and more. We have many features on this website to make your experience here more enjoyable.

Join in and contribute your ideas and questions! FYI: You must register and login to post replies or start new topics.

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Leak at city water connection
No permission to create posts
August 5, 2019
12:28 pm
Avatar
suec123
New Member
Members
Forum Posts: 2
Member Since:
May 23, 2018
sp_UserOfflineSmall Offline

Hi all, I hooked up my hose yesterday to the city water connection and noticed water coming out from under the bed across the floor.  I lifted the bed and water was  not dripping at the hose connector, the wall was dry but had water at the bottom.  Outside the water was dripping from under the trailer and also at the connection.  It’s never done that before.  Any ideas?  Could it have come apart inside the wall somehow?  I’m not sure how to fix this..   It’s a 2014 150 Hybrid.  TIA. 

Cry

Forum Timezone: America/Denver

Most Users Ever Online: 177

Currently Online:
11 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

A.J.: 87

Alabama Jim: 54

mkevenson: 22

Perrypridgen: 20

markstevens: 19

thatchick1120: 18

DAVID555: 18

amber_bowers: 17

Groucho: 16

Captn Sharpie: 15

Member Stats:

Guest Posters: 0

Members: 884

Moderators: 1

Admins: 1

Forum Stats:

Groups: 5

Forums: 24

Topics: 306

Posts: 1148

Newest Members:

132422Rw18, famethdownrearo, ecpdba97, quepecenmori, MLBrown, AlexKutler, Ike, nckeehn, esplemremubip, omcialusttravath

Moderators: Roccosamore: 119

Administrators: Kristopher: 190