latest member photos

Welcome to the RV White Water Retro Travel Trailer Enthusiast Forums!

A website dedicated to all things Riverside RV Retro, tips, tricks mods and more. We have many features on this website to make your experience here more enjoyable.

Join in and contribute your ideas and questions! FYI: You must register and login to post replies or start new topics.

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Water system 177SE
No permission to create posts
July 22, 2018
3:58 pm
Avatar
mamagumbie
New Member
Members
Forum Posts: 2
Member Since:
July 22, 2018
sp_UserOfflineSmall Offline

Our first trip this season and we are completely flummoxed by the water system.  The pump is running but nothing coming through faucets etc.  The pump works when using the winterizing tail to suck up water from a bucket and that water cane through faucets.  Tank definitely had water. What are we missing?

July 23, 2018
2:31 pm
Avatar
Roccosamore
Moderator
Members

Moderators
Forum Posts: 119
Member Since:
September 24, 2016
sp_UserOfflineSmall Offline

Make sure your water by pass valves for the water heater are turned the right way. Under the dinette seat.

July 23, 2018
3:18 pm
Avatar
mamagumbie
New Member
Members
Forum Posts: 2
Member Since:
July 22, 2018
sp_UserOfflineSmall Offline

Thank you.  I have tried with valves in both positions. I am assuming that the valve is open when the handle is in line with the water line.  (The points of the oval handle following the pipe ).  Thanks again.

November 19, 2018
2:48 pm
Avatar
Hamman5253
New Member
Members
Forum Posts: 2
Member Since:
November 19, 2018
sp_UserOfflineSmall Offline

Make sure the valve to the fresh water tank is open and the value to the winterize tail is closed.  Also make sure that when you start the pump all faucets (including outdoor shower) are in the closed position, then open faucets as needed.  

If no water is coming from your fresh water tank my bet is that valve is closed.  Find the hose (same place as the winterize tail) follow the hose with your hand toward the fresh water tank (goes behind where the fuse box is located).  You will feel the valve, make sure it is open. Note: you cannot have both valves (from fresh water tank and the winterize tail) open at the same time.

Forum Timezone: America/Denver

Most Users Ever Online: 61

Currently Online:
23 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

A.J.: 68

Alabama Jim: 54

markstevens: 18

Perrypridgen: 18

thatchick1120: 18

DAVID555: 18

amber_bowers: 17

Groucho: 16

Captn Sharpie: 15

Libacon: 14

Member Stats:

Guest Posters: 0

Members: 686

Moderators: 1

Admins: 1

Forum Stats:

Groups: 5

Forums: 24

Topics: 263

Posts: 1000

Newest Members:

yukonhulio, forbestm87, cottersay, brianscottesp, Luffman, Winston Rudolph, Harry Tiffany, Debbie, Tomjkel, IQBlonde

Moderators: Roccosamore: 119

Administrators: Kristopher: 178