Welcome to the RV White Water Retro Travel Trailer Enthusiast Forums!

A website dedicated to all things Riverside RV Retro, tips, tricks mods and more. We have many features on this website to make your experience here more enjoyable.

Join in and contribute your ideas and questions! FYI: You must register and login to post replies or start new topics.

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Furnace Issue
No permission to create posts
November 24, 2018
4:45 am
Avatar
A.J.
Member
Members
Forum Posts: 83
Member Since:
March 3, 2017
sp_UserOfflineSmall Offline

 Hello,

I searched the site to see if this was previously discussed without success:  I am not able to get my furnace to work.  When I adjust my thermostat to fire up the furnace nothing happens. All I know at this point is it is not a propane issue.  Other than that, I would love to hear your thoughts on trouble shooting.

A.J.

January 27, 2019
3:52 am
Avatar
TanishaLambertson
Member
Members
Forum Posts: 8
Member Since:
January 19, 2019
sp_UserOfflineSmall Offline

First of all, you didn’t mention here which furnace are you using but I can guess, you are using a gas furnace. Here, you can see the reasons why your furnace is not getting fire https://www.assuredcomfort.com/news/5-reasons-why-your-furnace-is-not-igniting. In addition, I would suggest you prefer an electric fireplace ( https://bestazy.com/best-electric-fireplace/ ) instead of a gas furnace. However, if you still don’t find a solution then you should check your programmable thermostat for an error code. 

January 28, 2019
9:42 am
Avatar
Kristopher
Southern Utah
Admin
Forum Posts: 186
Member Since:
June 25, 2016
sp_UserOfflineSmall Offline

I had a furnace issue it ended up being my control board. There was not enough fresh air cooling and it burned up the board. We added a fresh air vent.

Forum Timezone: America/Denver

Most Users Ever Online: 61

Currently Online:
9 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

A.J.: 83

Alabama Jim: 54

thatchick1120: 18

DAVID555: 18

Perrypridgen: 18

markstevens: 18

amber_bowers: 17

Groucho: 16

Captn Sharpie: 15

Libacon: 14

Member Stats:

Guest Posters: 0

Members: 806

Moderators: 1

Admins: 1

Forum Stats:

Groups: 5

Forums: 24

Topics: 284

Posts: 1092

Newest Members:

marjry11278, Ballanjl, Bigfoot1, squdgee, ragram, Otterdad, Brian Y, Ksulli123, TerryC, Coopedup7928

Moderators: Roccosamore: 119

Administrators: Kristopher: 186