latest member photos

Welcome to the RV White Water Retro Travel Trailer Enthusiast Forums!

A website dedicated to all things Riverside RV Retro, tips, tricks mods and more. We have many features on this website to make your experience here more enjoyable.

Join in and contribute your ideas and questions! FYI: You must register and login to post replies or start new topics.

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Electrical
No permission to create posts
May 13, 2018
7:13 am
Avatar
benchy
Member
Members
Forum Posts: 6
Member Since:
May 5, 2018
sp_UserOfflineSmall Offline

Just purchased 2016 177 SE from person who only used it once. Cannot get any of the 12 fold systems to work, such as the fan and the dome lights over the bed and stove. Battery is fully charged and hooked up. It is in our driveway and also hooked up to 110 V AC any suggestions? Is it the converter and if so where is it located?

May 13, 2018
8:06 am
Avatar
Roccosamore
Moderator
Members

Moderators
Forum Posts: 119
Member Since:
September 24, 2016
sp_UserOfflineSmall Offline

Your electrical panel is the brown box below the refrigerator. Check fuses and switches to see they are good. If not, you may need to have a repair person look at it.

June 1, 2018
10:26 pm
Avatar
lgppgl
New Member
Members
Forum Posts: 1
Member Since:
June 1, 2018
sp_UserOfflineSmall Offline

Hello… I just bought a retro jr…. any recommendations for a small heater for It?  Maybe one that can mount in one of the cabinets?

Also has any one tried to add a 12v plug in the kitchen?  When plugged in to 30amp the 120 outlet isn’ powered???

June 4, 2018
7:01 am
Avatar
Roccosamore
Moderator
Members

Moderators
Forum Posts: 119
Member Since:
September 24, 2016
sp_UserOfflineSmall Offline

As stated above, check breakers and fuses. If it still doesn’t work your going to have a repair person check it. All outlets should work on shore power.

Forum Timezone: America/Denver

Most Users Ever Online: 57

Currently Online:
34 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

A.J.: 67

Alabama Jim: 54

Perrypridgen: 18

thatchick1120: 18

DAVID555: 18

markstevens: 18

amber_bowers: 17

Groucho: 16

Captn Sharpie: 15

Libacon: 14

Member Stats:

Guest Posters: 0

Members: 643

Moderators: 1

Admins: 1

Forum Stats:

Groups: 5

Forums: 24

Topics: 252

Posts: 978

Newest Members:

nshep82, BILLSTJOHN, Leahbrob, clestes1, T.Estes, esullivan1953, justus2, Janineretro195, Ritags, BenGlen-NH

Moderators: Roccosamore: 119

Administrators: Kristopher: 178